1

I am trying to set up a private tangle and I cannot compute merklee tree. I followed this link:

https://docs.iota.org/docs/compass/0.1/how-to-guides/set-up-a-private-tangle#step-2-compute-the-merkle-tree

[I tried building the layers_calculator tool that will compute the Merkle tree as mentioned in link and when I try to execute this statement bazel run //docker:layers_calculator. It does not show any error or any output.]

Your timely assistance will mean a lot, Thank you!

  • What parameters did you use, how long did you let it run, and how fast is your machine? Merkle tree computation is computationally intensive, compare docs.iota.org/docs/compass/0.1/references/… – mihi Jan 28 at 22:08
  • I am sorry, I am neophyte. I just followed the link, I am trying to build layers_calculator tool to compute Merklee tree (as I am following above mentioned link). I tried running it for couple of mins (at least 15min), it does not build. As far my machine being fast I have assigned it 5 gb with with 2 cores per processor (3 processors). Its intensiveness will be much less of worry if I get to build layers_calculator to compute merklee tree first! – Muhammad Bilal Jan 30 at 4:54
  • ah okay, you don't even get to the point where you could compute the Merkle tree, since you cannot build layers_calculator... Sorry that I misunderstood you. – mihi Jan 30 at 21:19
  • but generally, bazel is working for you? (try bazel version or bazel info release)? – mihi Jan 30 at 21:23
  • 1
    I got couple of warnings but I also I got this: Build label: 0.18.0 Build target: bazel-out/k8-opt/bin/src/main/java/com/google/devtools/build/lib/bazel/BazelServer_deploy.jar Build time: Mon Oct 15 08:33:18 2018 (1539592398) Build timestamp: 1539592398 Build timestamp as int: 1539592398 – Muhammad Bilal Feb 1 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.