1

As part of my PhD project, I managed to install two Hornet nodes, one on my laptop and one on my RPi 4. However, I can't install the iota_client on the RPi to start the coding process. Specifically, although I install maturin, I can't proceed with the develop and build commands. It prints that the maturin command is unknown.

Any kind of help is appreciated!

1 Answer 1

0

These are my setup nodes for iota.rs on the Raspberry PI 4

Let me know if these help.

Shimmer IOTA.rs on RPI4 without venv

Debian Lite Bullseye 64bit

Source guide: https://github.com/iotaledger/iota.rs/tree/develop/client/bindings/python/native

Install prerequisited

sudo apt install git python3-pip clang libdbus-1-dev libusb-dev libhidapi-dev libhidapi-hidraw0 libudev-dev

Upgrade pip to latest version

pip install --upgrade pip

Install Rust

curl https://sh.rustup.rs -sSf | sh

Reload enviroment

source "$HOME/.cargo/env"

Get repo

git clone https://github.com/iotaledger/iota.rs.git

Build

cd iota.rs/client/bindings/python/native

pip install -r requirements-dev.txt

pip install .

2
  • As additional information yesterday the team released the iota-sdk 1.0, the first stable version of the new rust-based project. It’s a major upgrade combining iota.rs & wallet.rs, offering an efficient way to interact with nodes. I still have to try to set ip up on a RPI4, but let me know it that works for you Commented Jul 25, 2023 at 6:49
  • Hello and sorry for not replying back all these months. Apparently, there were some issues with the available documentation back then. I had to make some modifications according to some material I found online. However, with the latest updates it installs perfectly. Commented Nov 16, 2023 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.