9

I run my IOTA node inside a VPC, behind a firewall;

I would like to be able to access the API from another host then localhost, but that is where IRI has bound:

$ cat bin/iota.ini | grep PORT
PORT = 14700

$ netstat -ln | grep 14700
tcp6       0      0 127.0.0.1:14700         :::*                    LISTEN

How can I make IRI bind to all IPs?

5

if you use a .ini config file, you can also add this to it

API_HOST = 0.0.0.0
  • Marking this as the correct answer, is it is what I ended up using. – Matt Clark Nov 30 '17 at 0:03
5

You have to start IRI using the --remote flag. and don't forget to disable some API calls. For example: 

java -jar iri.jar -p 14700 -r 14700 -n "udp://neighbor1:14265" --remote-limit-api "removeNeighbors, addNeighbors, interruptAttachingToTangle, attachToTangle, getNeighbors" --remote

See here for other IRI startup flags

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.