Questions tagged [cli-wallet]

This Tag is used for Questions on the official iota Cli-Wallet.

Filter by
Sorted by
Tagged with
0 votes
0 answers
17 views

cli-wallet for linux ERROR: `Node error: Couldn't get a result from any node`

i tried to use cli-wallet from this link https://github.com/iotaledger/cli-wallet and download the release version 0.5.4 to create wallet account in private tangle and encountered this error: ./wallet-...
1 vote
0 answers
20 views

double spend script is not working!

I'm running a private tangle network (GoShimmer 1.7.2) using Docker https://goshimmer.docs.iota.org/tooling/docker_private_network.html I want to try a double spend. there is a script to do that in ...
  • 123
3 votes
0 answers
110 views

How to create multiple wallet addresses for a single node?

I'm tring to create a website where iota of multiple users can be stored in a wallet using php. Function needed are separate address for each user and they should be able to retrieve balance. I do ...
  • 191
4 votes
0 answers
148 views

How to connect cli-app with IOTA Javascript Library

I installed IOTA CLI Wallet and executing 'iota-cli' works after iri is executed. I get NodeInfo command run on iota-cli from my terminal also. So I guess a stand alone IOTA wallet core is now ...
  • 191
2 votes
1 answer
127 views

Cli-Wallet error: COMMAND attachToTangle is not available on this node

I tried to generate new addresses. During registration in the tangle following happened: iota (http://PrivateNode:Port ✓) 0ι : address One minute while we generate the address. The address is ...
  • 1,607
3 votes
1 answer
26 views

Cli-Wallet is not running. How to fix it?

After perfoming: user@Device:~$ iota-cli I get following Error: /usr/local/lib/node_modules/iota-cli-app/lib/config.js:83 get, ^ SyntaxError: Unexpected token , at exports....
  • 1,607
1 vote
1 answer
105 views

How to use Cli-Wallet with a custom node?

So I installed Node.js and Cli-Wallet. No when I try to start the wallet, following error occures: user@Device:~$ iota-cli /usr/bin/env: ‘node’: No such file or directory How can I fix it? I can't ...
  • 1,607