5

These are the first messages in the log after booting

12/19 07:08:03.158 [pool-2-thread-1] INFO  c.i.iri.network.TransactionRequester - Removed existing tx from request list: ZQRK9RDRQZIL9XEYDAMMABTWSSNED9GMD                                             OJY9DZUT9AN9TCUCCJDHRUTAMZLBNGGPHJDSMZW9YGIA9999
12/19 07:08:09.787 [pool-2-thread-2] INFO  com.iota.iri.network.Node - toProcess = 0 , toBroadcast = 0 , toRequest = 2 , toReply = 0 / totalTransactions =                                              6912778
12/19 07:08:19.790 [pool-2-thread-2] INFO  com.iota.iri.network.Node - toProcess = 0 , toBroadcast = 0 , toRequest = 4 , toReply = 0 / totalTransactions =                                              6912877

all is ok until

12/19 07:19:00.160 [pool-2-thread-2] INFO  com.iota.iri.network.Node - toProcess = 0 , toBroadcast = 0 , toRequest = 3 , toReply = 0 / totalTransactions = 6913396
12/19 07:19:05.330 [pool-5-thread-1] ERROR com.iota.iri.network.Node - Invalid transaction address
12/19 07:19:05.331 [pool-5-thread-1] ERROR com.iota.iri.network.Node - Received an Invalid TransactionViewModel. Dropping it...
12/19 07:19:10.162 [pool-2-thread-2] INFO  com.iota.iri.network.Node - toProcess = 0 , toBroadcast = 0 , toRequest = 2 , toReply = 0 / totalTransactions = 6913421

then again all is ok until

12/19 07:27:00.315 [pool-2-thread-2] INFO  com.iota.iri.network.Node - toProcess = 0 , toBroadcast = 0 , toRequest = 1 , toReply = 0 / totalTransactions = 6913766
12/19 07:27:04.626 [pool-3-thread-6] ERROR com.iota.iri.network.Node - Invalid transaction address
12/19 07:27:04.626 [pool-3-thread-6] ERROR com.iota.iri.network.Node - Received an Invalid TransactionViewModel. Dropping it...
12/19 07:27:04.884 [pool-5-thread-1] ERROR com.iota.iri.network.Node - Invalid transaction address
12/19 07:27:04.884 [pool-5-thread-1] ERROR com.iota.iri.network.Node - Received an Invalid TransactionViewModel. Dropping it...
12/19 07:27:05.438 [pool-5-thread-1] ERROR com.iota.iri.network.Node - Invalid transaction address
12/19 07:27:05.438 [pool-5-thread-1] ERROR com.iota.iri.network.Node - Received an Invalid TransactionViewModel. Dropping it...
12/19 07:27:05.484 [pool-5-thread-1] ERROR com.iota.iri.network.Node - Invalid transaction address
12/19 07:27:05.484 [pool-5-thread-1] ERROR com.iota.iri.network.Node - Received an Invalid TransactionViewModel. Dropping it...

but now the log is full of dropped transactions. I get multiple of those per second at times.

It's almost like every tx triggers this message. Every time I see a new tx in the ZeroMQ client, such a message pops up in the log. I think not for each single one, but sometimes I get more or less errors than the tx shown in ZeroMQ. But this may well be because of some sort of batching, where multiple tx come in and some of them are invalid.

4

Iri 1.4.1.4 has stricter transaction validity checks than previous versions (to avoid invalid transactions from spreading too far).

So if one of your neighbors has not yet upgraded, they will try to send you that invalid (but valid from their perspective) transaction over and over.

Remove that neighbor or tell him to upgrade as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.