2

I try the sendTransfer command on my full node. After long time, I get this error:

Error: Invalid Response: 
    at Object.invalidResponse (/home/atena/iota/node_modules/iota.lib.js/lib/errors/requestErrors.js:5:12)
    at makeRequest.prepareResult (/home/atena/iota/node_modules/iota.lib.js/lib/utils/makeRequest.js:160:24)
    at exports.XMLHttpRequest.request.onreadystatechange (/home/atena/iota/node_modules/iota.lib.js/lib/utils/makeRequest.js:62:25)
    at exports.XMLHttpRequest.dispatchEvent (/home/atena/iota/node_modules/xmlhttprequest/lib/XMLHttpRequest.js:591:25)
    at setState (/home/atena/iota/node_modules/xmlhttprequest/lib/XMLHttpRequest.js:610:14)
    at IncomingMessage.<anonymous> (/home/atena/iota/node_modules/xmlhttprequest/lib/XMLHttpRequest.js:447:13)
    at emitNone (events.js:110:20)
    at IncomingMessage.emit (events.js:207:7)
    at endReadableNT (_stream_readable.js:1059:12)
    at _combinedTickCallback (internal/process/next_tick.js:138:11)

Any idea?

Edit: Adding my client call code:

var IOTA = require('iota.lib.js');

var iota = new IOTA({
    'host': 'http://my.node.ip',
    'port': port
});

// now you can start using all of the functions
iota.api.sendTransfer('seed', 5, 15, 
    [{
        'address': 'AZAVFJ9SSYLLGXXLBCIWFDZWDTUVAREHPPEXQGMAXRKDKDUXWKWRKLLHNWPEDYJ9WJNGJFCJWPGJSVNKX',
        'value': 10
    }],
    function(error, success) {
    if (error) {
        console.error(error);
    } else {
        console.log(success);
    }
})
  • Can you show us your code as well (careful not to share the seed)? With what parameters did you call sendTransfers? Please edit your question. – Zauz Dec 2 '17 at 18:35
  • Also, do you have any error messages in the log of your full node? – mihi Dec 2 '17 at 20:43
  • No error log (that I saw) in my full node. – Agustin Tena Dec 3 '17 at 11:59
  • Have you tried different seeds or is it isolated to a specific seed? – slippedon Dec 4 '17 at 1:13
  • just tried with my personal seed – Agustin Tena Dec 4 '17 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.