3

I run a removeNeighbour command on my full node over curl but my node seems ignoring me.

curl http://my.iota.node:port \
  -X POST \
  -H 'Content-Type: application/json' \
  -H 'X-IOTA-API-Version: 1' \
  -d '{"command": "removeNeighbors", "uris": 
["tcp://neighbour.to.remove:port"]}'

I always get a {"removedNeighbors":0,"duration":150}.

I tried with other neighbours and it works just fine. But this specific one doesn't. I am sure I have this neighbour and I am writing the address right.

  • up vote 0 down vote accept I still do not know why this happened. However I got my neighbour removed by removing it from the config .ini file and restarting the node. Ugly, but that's it. It will be nice to know why my node ignored my command though. – Agustin Tena Dec 3 '17 at 20:50
1

Can it be that you are using the hostname, and the IP address of the neighbor changed since adding or restarting your node? To remove neighbors, your node compares protocol, resolved IP and port. In case the IP changed while your IRI was running, removing it with the same host name will fail (but removing it with the old IP should still work).

You can also try to restart your iri and check if the removal works afterwards.

  • Not changed anything about this neighbour actually. But thanks. – Agustin Tena Dec 3 '17 at 11:56
  • and are you using the hostname or the IP to add the neighbor? TCP or UDP neighbor? – mihi Dec 3 '17 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.