1

I just started looking at Shimmer network and I wanted to setup a node. I'm on Ubuntu. I've followed the setup guide but when I run the command "wasp -c wasp-node', 'wasp' command not found.

1 Answer 1

1

A few things to note:

  1. You've successfully built the binaries.
  2. The location of your binaries.

You can follow the guide here to install properly: Installing Wasp on Wiki.

If you're setting up using make build then the binaries ideally stay in the root directory. In which case, you'd need to run: ./wasp instead of wasp. If you've run make install, then the binaries should be on the global path and be accessible using wasp. If you do not have go path setup, follow this.

1
  • Thank you for responding. I followed the instructions here, wiki.iota.org/shimmer/smart-contracts/guide/chains_and_nodes/…. Though my PATH for Go is '/usr/local/go/bin/go', I can still run the 'go' command from anywhere. I used the 'make install' command. When I run 'wasp', I get 'no such file or directory'. If I run './wasp', I get a 'Command 'wasp' not found, did you mean:...' but no command example for 'wasp'.
    – Jay
    Oct 21, 2022 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.