1

I am trying to setup a WASP Chain to test deploy a EVM smart contract. However, I try to wasp-cli request-funds or wasp-cli chain deploy I am getting a dial tcp connect:connection refused error. enter image description here

This is what my wasp-cli.json looks like.

enter image description here

How can I resolve this error? Your help is very much appreciated. Thank you.

1 Answer 1

1

This error was due to setting up only 1 WASP node but configurign for more than the existing number of nodesin the wasp-cli.json. Upon removing the "1" and "n" node configurations, chain deployment has been successful. In addition, the goshimmer api node has been outdated and must be updated to wasp-cli set goshimmer.api https://api.goshimmer.sc.iota.org

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.