1

I've set up a private tangle following the guide on iotaledger/compass. Now I'm trying to enable zmq. I tried to change the following in the 03_run_coordinator.sh file. Changes are adding the 5556 port and the zmq_enabled configuration.

docker pull iotaledger/iri:latest
docker run -p 5556:5556 -t --net host --rm -v $scriptdir/db:/iri/data -v $scriptdir/snapshot.txt:/snapshot.txt -p 14265 iotaledger/iri:latest \
       --testnet \
       ..
       --zmq_enabled true

Unfortunately, it seems like zmq is still disabled.

  • Does the Coordinator support ZMQ? You should add it to 02_run_iri.sh if you want to enable ZMQ for your node. – Akkumulator Jan 13 at 16:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.