I run a node I setup after the manual of http://iota.partners/

I recently completely wiped it and installed the newest lubuntu 18.04 on it, but I had the same problems before. Yesterday I set everything back up and it worked flawlessly! But overnight, it again got stuck at some milestones. A lot of people, that successfully run nodes for months, tried to help me, with no results. Sure, I can always redownload the DB and everything (even in a single command), but that can't be the solution to the issue. I run it together with carriota-field, but nothing else.

What I did so far:

  • Run everything with sudo rights.
  • sudo chmod -R 777 /../../iota-node (I know...)
  • Allocate 6GB of RAM to the iri
  • Restart the node
  • Use less neighbors (tried 3 - 8), always same result. Newest try was 5.
  • Several config tweaks...

Any ideas are appreciated.

  • Try to get the logs to see if you can get some clues there. And what do you see precisely? Latest milestone index not increasing ? What about storage space ?
    – ben75
    May 13, 2018 at 10:18
  • @ben75 The logs look normal, ai can see how the node just continue and always updates the latest milestone. But the solid milestone is stuck somehow. Very weird. 200GB free space on the SSD where the node is running.
    – codepleb
    May 13, 2018 at 11:28
  • Yes same problem on my side with Ubuntu 16.04.4 LTS, newest iri-Node 1.5.0 with nelson, runs good for while with max 15 neighbours, next day it is down, the service is running but no CPU use with usual memory alloc ...
    – MiXiM
    Jun 29, 2018 at 18:50
  • I still have the issue here and there, but tangletools.com helps with their watchdog service, that will inform you when your node goes into an unsynced state.
    – codepleb
    Jun 29, 2018 at 22:13

1 Answer 1


Since this question is still getting upvotes, here is an answer (more of an approximation) by myself, having kind of a solid knowledge about it as of now, running a node and actively developing stuff for the iri.

  • When I fire a lot of requests to my node, it here and there crashes. It's not denial of service or anything, but maybe 2 requests per second.
  • When a new iri version comes out, my node seems to go immediately offline.
  • I made my whole folder with the iota stuff in it owned by the root user and only handle it with that one. That really helped!
  • I have a command that stops the iri, remove the db, redownloading the db and starts the iri, so this takes away the pain to "boot up" after it getting stuck. Here is how it looks for my case: systemctl stop iota && rm -fr /home/user/iota/node/mainnetdb && mkdir /home/user/iota/node/mainnetdb/ && cd /home/user/iota/node/mainnetdb/ && curl -L http://db.tangletools.org/mainnetdb.tar.gz | tar zx && systemctl start iota && cd ..

I hope that helped you at least a bit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.