6

It is basically all in the title. What iri settings are needed to delegate my POW to my Fullnode?

4

To enable POW in your fullnode just open this file in a Texteditor like nano:

nano /home/iota/node/iota.ini

You will see this:

[IRI]
PORT = 14265
UDP_RECEIVER_PORT = 14600
TCP_RECEIVER_PORT = 15600
API_HOST = 0.0.0.0
IXI_DIR = ixi
HEADLESS = true
DEBUG = false
TESTNET = false
DB_PATH = mainnetdb
RESCAN_DB = false

REMOTE_LIMIT_API = "removeNeighbors, addNeighbors, interruptAttachingToTangle, attachToTangle, getNeighbors, setApiRateLimit"

NEIGHBORS = udp://IP:PORT 
EOF

Just delete attachToTangle and interruptAttachingToTangle under REMOTE_LIMIT_API, so it looks like:

REMOTE_LIMIT_API = "removeNeighbors, addNeighbors, getNeighbors, setApiRateLimit"

Now you have to restart you Fullnode using the command:

sudo service iota start

That's it. Now your fullnode can do POW.

  • is IRI_OPTIONS = "--remote" obsolete? – Akkumulator Feb 12 '18 at 10:54
  • Following link there is no need for IRI_OPTIONS = "--remote" and enabling POW like given, was sufficient for me. – Tobi MZ Feb 14 '18 at 10:09
  • Good to know. I found by setting it, the API_HOST ist set to 0.0.0.0, basically what you specified explicitly. github.com/iotaledger/iri/blob/… – Akkumulator Feb 14 '18 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.