Excuse me, can you please help me, when I launch IOTA Wallet (full version) with a few neighboring nodes added, the wallet reports following error:

12/28 16:55:24.416 [main] INFO  com.iota.iri.IRI - Welcome to IRI
Exception in thread "main"
java.lang.UnsatisfiedLinkError: C:\Users\User\AppData\Local\Temp\librocksdbjni7861117433009785088.dll: A dynamic link library (DLL) initialization routine failed
at java.base/java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.base/java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.base/java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.base/java.lang.Runtime.load0(Unknown Source)
at java.base/java.lang.System.load(Unknown Source)
at org.rocksdb.NativeLibraryLoader.loadLibraryFromJar(NativeLibraryLoader.java:78)
at org.rocksdb.NativeLibraryLoader.loadLibrary(NativeLibraryLoader.java:56)
at org.rocksdb.RocksDB.loadLibrary(RocksDB.java:64)
at org.rocksdb.RocksDB.<clinit>(RocksDB.java:35)
at com.iota.iri.storage.rocksDB.RocksDBPersistenceProvider.<init>(RocksDBPersistenceProvider.java:28)
at com.iota.iri.Iota.initializeTangle(Iota.java:201)
at com.iota.iri.Iota.init(Iota.java:92)
at com.iota.iri.IRI.main(IRI.java:86)
12/28 16:55:41.945 [Shutdown Hook] INFO  com.iota.iri.IRI - Shutting down IOTA node, please hold tight...
12/28 16:55:47.956 [Shutdown Hook] ERROR com.iota.iri.IRI - Exception occurred shutting down IOTA node:
java.lang.NullPointerException: null
at com.iota.iri.network.replicator.ReplicatorSourcePool.shutdown(ReplicatorSourcePool.java:76) ~[iri.jar:na]
at com.iota.iri.network.replicator.Replicator.shutdown(Replicator.java:30) ~[iri.jar:na]
at com.iota.iri.Iota.shutdown(Iota.java:176) ~[iri.jar:na]
at com.iota.iri.IRI.lambda$shutdownHook$0(IRI.java:259) ~[iri.jar:na]
at java.base/java.lang.Thread.run(Unknown Source) ~[na:na]
Process exited with status 1

Why do I get such an error and what can I do about it?

  • 1
    Is your installed Java version 64 bit? Full node does not run on 32-bit Java on Windows as they don't provide native libraries for 32-bit Windows. Install 64-bit Java instead.
    – mihi
    Commented Dec 28, 2017 at 18:35
  • Is there a solution about the problem? I have the same thing error. Fullnode, Windows 64 bit, newest wallet iri. Same Error. When i run Light Wallet with Public node it works, but if i want to run wallet with full node and with costum localhost:14265 then i have error in wallet "No Connection" No Connection to remote node. What am i doing wrong?
    – Niuran78
    Commented Jan 21, 2018 at 1:02

1 Answer 1


Seems rocksDB related setup. Did you use instructions from a walkthrough guide such as http://iota.partners/ ? Also running a full node which will not be online 24/7 is a bad idea it wont help the network a great deal. In other words refrain from running the full node wallet on desktops and laptops.

  • Thank you for your response. I have installed 64 bit Java is ok. I get the same error when I build the iri with maven (mvn clean compile passess ok, in mvn package there is the problem): Tests in error: com.iota.iri.BundleValidatorTest: C:\Users\User\AppData\Local\Temp\librocksdbjni16850478755329069913.dll: A dynamic link library (DLL) initialization routine failed. There is no RocksDB dll in this directory: C:\Users\User\AppData\Local\Temp Yes, this is surely the problem is with the RocksDB dll, which is quite important component of the IRI. Does anybody know how to fix this ?
    – PavelM
    Commented Dec 29, 2017 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.